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Learning	how	to	use	grids	and	guides	in	Photoshop	is	useful	to	compose	your	project	and	put	objects	in	the	exact	position	you	need	them.	They	arent	difficult	to	use	once	you	know	how	to	set	them	up	and	use	the	different	settings.	Lets	take	an	in-depth	look	at	how	to	make	Photoshops	grids	and	guides	work	for	you.	To	use	a	grid	in	Photoshop,	go	to
View	>	Show	>	Grid	to	reveal	a	grid	overlay	on	your	canvas.	To	adjust	the	look	of	the	grid,	go	to	Photoshop	>	Preferences	>	Guides,	Grid	&	Slices.	Within	the	Grid	settings,	choose	a	grid	size,	color,	and	line	type	to	suit	your	needs.	A	grid	is	an	overlay	you	can	add	to	your	canvas	that	can	help	you	compose	your	project.	The	grid	only	shows	up	while
youre	working	on	the	project	when	you	export,	the	grid	will	be	gone.	The	grids	main	purpose	is	as	a	composition	tool,	helping	you	align	objects.	This	can	be	especially	useful	for	landscape	photographers	trying	to	straighten	the	horizon,	or	for	architecture	photographers	working	with	lots	of	lines	and	angles.	To	add	a	grid	to	your	project,	head	to	View
>	Show	>	Grid.	On	a	blank	canvas,	itll	look	something	like	this.	There	are	some	instances	when	you	might	need	to	change	the	size	of	the	space	between	grid	lines.	When	you	add	a	grid	to	your	canvas,	the	size	is	set	automatically.	But	occasionally	the	grid	appears	too	large	or	small	for	the	project	youre	working	on.	For	instance,	the	photo	I	uploaded
below	was	too	big	for	the	tiny	grid	to	be	of	any	use.	So,	to	change	the	size	of	the	spaces	between	grid	lines,	head	to	Photoshop	>	Preferences	>	Guides,	Grid	&	Slices.	In	the	Grid	section,	you	can	change	the	number	and	unit	of	measurement	of	the	space	between	each	gridline.	Lets	take	the	example	in	the	photo	above	and	increase	the	spacing
between	the	grid	lines	since	a	gridline	every	2	centimeters	is	much	too	close.	Lets	alter	the	settings	so	that	there	is	a	gridline	every	10	centimeters.	That	size	fits	the	photo	much	better.	Now,	using	the	grid,	I	can	line	up	elements	like	sections	of	the	road,	the	trees,	and	the	side	of	the	house	to	create	the	cleanest	composition.	To	create	a	new	guide	in
Photoshop,	press	Command/Control	+	R	to	reveal	the	ruler,	then	select	the	Move	Tool	by	pressing	V.	Clicking	on	the	horizontal	or	vertical	ruler	around	your	canvas,	drag	outwards	to	reveal	a	new	guide	on	your	image.	To	delete	these	guides,	go	to	View	>	Clear	Guides.	Guides	are	similar	to	grids	in	that	both	give	you	a	visible	set	of	lines	to	help	you
place	objects,	align	elements,	or	otherwise	compose	your	project.	However,	unlike	Grids,	you	set	the	guides	yourself,	giving	you	even	more	control	over	what	visual	guidelines	you	can	see	on	your	canvas.	It	can	be	helpful	to	have	rulers	showing	while	working	with	guides,	so	to	enable	rulers,	head	to	View	>	Rulers	or	click	Command	+	R	on	a	Mac	or
Control	+	R	on	a	PC.	Now	rulers	will	appear	at	the	top	and	side	of	your	project	in	the	unit	of	measurement	set	in	your	preferences.	Now	to	create	a	new	guide,	head	to	View	>	New	Guide.	In	the	window	that	comes	up,	choose	whether	youd	like	your	guide	to	appear	vertically	or	horizontally.	Enter	a	position	if	youd	like	otherwise,	the	guide	will	appear
at	the	start	of	your	canvas.	Click	OK.	Now,	the	guide	will	appear	in	the	orientation	and	position	you	set.This	method	is	easiest	for	setting	a	guide	in	a	certain	part	of	your	canvas	automatically.	Once	a	guide	is	created,	you	can	use	the	Move	Tool	to	drag	it	into	a	new	position	on	your	canvas.	You	can	also	create	guides	once	you	have	rulers	visible	on
your	project	by	simply	clicking	and	dragging	either	the	horizontal	ruler	to	create	a	horizontal	guide,	or	the	vertical	ruler	to	create	a	vertical	guide.	With	the	Move	Tool	active,	click	the	ruler	and	drag	towards	your	canvas	and	the	guide	will	appear.	You	can	create	as	many	guides	as	you	need	and	move	them	about	your	canvas.	Now	to	remove	your
guides,	head	to	View	>	Clear	Guides.	Manual	guides	take	a	second	to	set	up,	so	if	youre	looking	for	a	quick	fix,	Smart	Guides	are	a	great	method	to	quickly	align	elements	without	having	to	go	through	the	steps	of	creating	a	guide	yourself.	Smart	Guides	should	be	on	automatically,	but	to	make	sure,	head	to	View	>	Show	>	Smart	Guides.	If	there	is	a
checkmark,	the	guides	are	enabled.	Once	youve	enabled	smart	guides,	theyll	show	up	while	youre	moving	objects	to	help	guide	where	they	can	go	as	well	as	show	their	relation	to	other	objects.	Notice	how	the	smart	guide	below	tells	me	when	the	pink	and	black	rectangles	are	perfectly	aligned.	For	me,	the	smart	guides	appear	in	pink,	but	well	cover
how	to	change	the	color	in	a	moment.	Maybe	youd	like	to	create	guides	in	the	very	center	of	the	canvas.	The	simplest	way	to	do	this	is	to	head	to	View	>	New	Guide.	In	the	window	that	comes	up,	select	whether	youd	like	a	vertical	or	horizontal	guide.	In	the	Position	box,	enter	50%	and	click	OK.	A	guide	will	appear	in	the	center	of	your	canvas	in	the
orientation	you	chose.	If	youd	like	both	vertical	and	horizontal	guides	running	through	the	center	of	your	canvas,	repeat	the	same	step	for	the	other	orientation.	Youll	now	see	both	guides	centered.	To	make	sure	you	dont	accidentally	move	these	guides,	follow	the	steps	in	the	next	section	to	lock	them	in	place.	Because	Guides	are	so	easy	to	move,	you
may	accidentally	click	and	drag	them	while	youre	working	on	your	project.	Luckily,	you	can	lock	guides	to	a	fixed	position	so	that	they	dont	get	in	the	way	of	your	workflow.	To	lock	all	the	guides	on	your	canvas,	go	to	View	>	Lock	Guides.	Now,	your	guides	will	stay	locked	in	place	as	you	work	on	your	project.	To	unlock	them	and	move	them,	just	click
View	>	Lock	Guides	again.	If	youd	like	your	guide	to	have	multiple	lines	with	specific	spacing,	you	can	quickly	create	a	custom	guide	layout.	This	is	much	faster	and	easier	than	creating	and	positioning	each	guide	individually.	To	create	a	new	guide	layout,	head	to	View	>	New	Guide	Layout.	In	the	window	that	appears,	you	can	choose	the	settings	for
your	new	guide	layout.	This	allows	you	to	add	as	many	rows	and	columns	as	you	need	to	your	guide,	as	well	as	specify	the	width	and	height	for	each.	You	can	also	set	the	size	of	the	gutter,	aka	the	space	between	the	lines.	Keep	in	mind	that	there	is	no	place	to	select	a	measurement	unit,	so	youll	have	to	type	the	measurement	youd	like	to	use	with	the
unit.	For	instance,	the	automatic	number	and	unit	size	of	my	gutter	is	1.693mm,	but	you	could	also	use	pixels,	points,	centimeters	whatever	works	best	for	your	project.	Youll	notice	the	guides	are	visible	on	the	canvas	and	change	as	you	edit	the	settings.	For	instance,	I	set	my	guides	to	have	the	following	settings:	These	guides	show	up	on	my	canvas
like	this:	When	youre	happy	with	how	the	guides	will	appear,	you	can	add	them	to	your	project	with	or	without	any	existing	guides	youve	already	added.	Once	on	your	project,	you	can	click	any	guidelines	youd	like	to	move,	so	I	suggest	locking	the	guides	to	avoid	clicking	and	moving	anything	accidentally	by	heading	to	View	>	Lock	Guides.	To	change
the	color	of	grids,	guides,	and	smart	guides	in	Photoshop,	go	to	Photoshop	>	Preferences	>	Guides,	Grid	&	Slices.	Here	you	can	choose	a	preset	color	from	the	drop-down	lists	provided,	or	click	the	color	swatches	on	the	right	to	choose	a	custom	color.	Lets	break	that	down	more	in-depth.	Once	your	grid	or	guides	are	in	place,	you	may	find	it	helpful	to
change	the	color	of	the	lines	if	they	blend	into	the	colors	of	your	project.	You	can	do	this	by	heading	to	Photoshop	>	Preferences	>	Guides,	Grid	&	Slices.	To	change	the	appearance	of	your	guides,	head	to	the	Guides	section.	Here,	you	can	change	the	colors	of	the	Guides	on	your	Canvas	and	Artboard,	as	well	as	the	Smart	Guides,	by	clicking	the	drop-
down	boxes	with	the	colors	on	them.	Youll	see	different	colors	to	choose	from	and	the	option	to	choose	a	custom	color.	You	can	also	change	the	type	of	line	that	appears	if	need	be.	In	the	preferences	window,	you	can	adjust	the	color	and	appearance	of	the	lines	in	the	grid	under	the	Grid	section.	Like	with	the	guides,	you	can	change	the	Color	by
clicking	the	drop-down	menu	and	choosing	or	customizing	a	color.	Next	to	the	Color,	you	also	can	change	the	type	of	line	you	see.	Once	youre	satisfied	with	your	new	colors,	click	OK.	While	working	with	grids	and	guides,	there	are	a	few	ways	you	can	optimize	your	workflow	and	speed	up	the	process	a	bit.	To	quickly	show	the	grid,	use	Command	+	on
a	Mac	and	Control	+	on	a	PC.	In	order	for	guides	to	function	at	their	best,	it	helps	to	have	the	rulers	visible	vertically	and	horizontally	on	your	canvas.	To	quickly	show	both	rulers,	use	Command	+	R	for	Mac,	and	Control	+	R	for	PC.	The	rulers	will	appear	at	the	top	and	side	of	your	canvas.	While	youre	working	with	guides,	you	can	change	the
orientation	of	a	specific	guide	by	holding	Option	on	a	Mac	and	Alt	on	a	PC,	and	clicking	the	guide.	The	orientation	will	switch	from	vertical	to	horizontal,	or	vice	versa.	You	can	easily	remove	guides	to	get	them	out	of	the	way	by	dragging	them	off	the	image	and	back	onto	the	ruler.	Photoshops	Snap	settings	help	you	place	objects	by	snapping	them	in
line	with	a	grid	or	guide,	depending	on	the	settings.	To	enable	snapping,	head	to	View	>	Snap	to	and	then	select	whether	youd	like	objects	to	snap	in	place	with	a	grid	or	guide.	Once	youve	made	your	selection,	there	will	be	a	checkmark	next	to	the	option	you	choose.	Snap	to	Grid	will	click	the	objects	in	place	with	the	grid	lines,	while	Snap	to	Guide
will	do	the	same	but	based	on	the	guides	youve	created.	Obviously,	you	need	the	grid	or	guides	present	in	your	canvas	before	you	can	snap	objects	to	them,	so	make	sure	youve	enabled	them	and	set	them	up	the	way	youd	like.	Sometimes,	though,	snapping	objects	can	prevent	you	from	placing	them	the	way	youd	like.	If	snapping	is	disrupting	your
workflow,	you	can	turn	it	off	by	heading	to	View	>	Snap	and	clicking	Snap	so	that	it	is	unchecked.	You	can	also	disable	snapping	temporarily	by	holding	down	Command	on	a	Mac	or	Control	on	a	PC	while	youre	placing	an	object,	but	keep	in	mind	this	only	works	with	the	Move	tool	active.	Grids	and	Guides	are	helpful	tools	for	a	variety	of	different
projects,	from	editing	photos	to	designing	graphics.	They	are	easy	to	use	once	youve	learned	the	ins	and	outs,	and	will	surely	help	you	with	creating	the	perfect	compositions	for	your	projects.	Happy	Editing!	Last	updated:	21/10/20244	min	readExpertPhotography	is	supported	by	readers.	Product	links	on	ExpertPhotography	are	referral	links.	If	you
use	one	of	these	and	buy	something,	we	make	a	little	money.	Need	more	info?	See	how	it	all	works	here.Photoshop	grids	and	guides	are	tools	to	make	editing	your	photos	easier.	Use	them	if	you	need	to	straighten	lines	in	a	photo	or	when	creating	a	layout.In	this	article,	Ill	show	you	how	to	use	them	both.How	Do	You	Make	a	Photoshop	Grid?Well	start
with	the	grid.	The	grid	is	non-printing	and	a	great	help	when	aligning	objects	or	laying	out	elements	symmetrically.Architecture	and	landscape	photographers	will	find	it	especially	helpful	to	straighten	buildings	and	horizons.Its	very	easy	to	make	a	grid	in	Photoshop.	Heres	how.Step	1.	Add	a	GridOpen	any	file	or	create	a	new	one.	Go	to	View	>	Show
and	choose	Grid	to	add	a	grid	to	your	workspace.	It	will	pop	up	immediately.The	grid	consists	of	lines	and	dotted	lines.	You	can	now	edit	the	appearance	of	the	lines,	units,	and	subdivisions.Step	2.	Edit	the	Photoshop	Grid	PreferencesGo	to	Photoshop	CC	>	Preferences	and	select	Guides,	Grid	&	Slices.	For	Windows,	go	to	Edit	>	Preferences	and	select
Guides,	Grid	&	Slices.A	new	window	will	pop	up	where	you	can	edit	the	preferences.You	can	change	the	color	of	the	lines	and	their	appearance.And	more	importantly,	you	can	set	how	far	apart	you	want	the	grid	lines	from	each	other.	Then,	depending	on	your	project,	set	how	many	subdivisions	you	want	between	the	main	lines.Step	3.
SnappingEnable	Snapping	if	you	want	Photoshop	to	help	you	place	objects.	Go	to	View	>	Snap	to	and	choose	Grid.Youll	notice	now	that	objects	will	click	into	place	on	your	grid.When	youre	finished,	turn	the	grid	off	again	to	check	out	your	design.How	to	Add	Guides	in	PhotoshopGuides	have	a	similar	purpose	but	the	difference	is	that	you	create	every
guideline	yourself.Step	1.	Adding	the	Ruler	in	PhotoshopBefore	you	can	add	guides,	you	need	to	add	the	rulers	to	your	workspace.	Go	to	View	and	select	Rulers.Two	rulers	will	appear.	One	on	the	left	and	one	at	the	top	of	the	workspace.You	can	also	change	the	Photoshop	ruler	preferences.	Go	to	Photoshop	CC	>	Preferences	and	select	Units	and
Rulers.A	new	window	will	pop	up	where	you	can	set	the	units	and	other	preferences.Step	2.	Add	GuidesTo	create	a	guide,	simply	click	on	one	of	the	rulers	and	drag	a	guide	onto	your	photo	or	layout.To	move	a	guide,	make	sure	the	Moving	tool	is	selected,	and	then	click	on	a	guide	and	drag	to	move	it.Once	you	have	created	all	the	guides	you	want,
you	can	lock	them.	Go	to	View	and	select	Lock	Guides.Step	3.	SnappingYou	can	also	add	Snapping	to	your	guides.	Go	to	View	>	Snap	to	and	select	Guides.Like	before,	this	will	make	objects	snap	or	click	into	place	along	your	guides.Step	4.	Remove	and	Hide	GuidesWhen	youre	finished,	you	can	either	clear	or	hide	guides	in	Photoshop.Go	to	View	and
select	Clear	Guides	to	remove	them.Go	to	View	>	Show	and	select	Guides	to	hide	or	make	them	reappear.ConclusionThe	Photoshop	grid	and	guides	are	useful	for	all	kinds	of	projects.	I	use	them	mostly	when	I	want	to	straighten	landscape	or	architecture	shots.If	you	like	graphic	design,	youll	want	to	use	the	grid	or	guides	for	laying	out	or	aligning
elements.It	is	definitely	worth	learning	how	to	use	them	and	can	make	a	huge	difference	in	your	post-processing	workflow.Want	to	improve	your	Lightroom	editing	skills	as	well?	Check	out	our	course	Effortless	Editing	with	Lightroom!Did	you	know	that	Photoshop	has	grids	and	guidelines?	If	youre	eyeballing	your	lines	every	time	youre	correcting	a
buildings	perspective,	straightening	a	horizon,	or	placing	a	logo	on	a	photo,	then	Photoshops	grids	and	guides	can	make	a	huge	difference.	(And	thats	not	even	taking	into	account	everything	you	can	do	with	the	tools	if	you	create	flyers	or	do	any	other	graphic	design	work.)In	this	article,	I	offer	a	quick	overview	of	Photoshops	positioning	tools.	I
explain	what	grids	and	guides	actually	are	and	how	to	create	them,	plus	I	share	some	tips	and	tricks	for	consistently	great	results.Lets	dive	right	in,	starting	with	the	basics:	A	grid	is	a	series	of	horizontal	and	vertical	lines	that	covers	Photoshops	canvas,	like	this:Grids	are	designed	to	make	it	easier	for	you	to	locate	specific	points	on	the	screen.	You
can	use	grids	to	create	symmetrical	designs	and	align	multiple	elements,	among	other	things.	Its	worth	noting	that	a	grid	is	just	a	visual	aid	inside	Photoshop;	the	gridlines	arent	saved	or	printed	on	the	image.	Guides	are	individual	lines	that	you	can	draw	across	the	Photoshop	canvas:Guides	can	be	used	to	create	designs,	straighten	elements,	control
spacing,	and	much	more.	They	can	be	horizontal	or	vertical	lines,	and	like	grids,	they	are	only	visual	aids	inside	Photoshop;	if	you	save	your	image	without	first	removing	your	guides,	the	lines	wont	appear	in	the	final	file.	Creating	a	grid	is	easy.	Simply	head	into	the	Photoshop	menu,	then	select	View>Show>Grid.	Take	a	look	at	your	image,	and	you
should	see	a	series	of	lines	crisscrossing	the	page.(Note:	Once	youve	enabled	grids,	if	you	select	View>Show,	youll	see	a	checkmark	next	to	the	Grid	option.	If	youre	ever	unsure	about	whether	grids	are	enabled,	simply	go	to	View>Show	and	look	for	that	checkmark!)Photoshops	grid	has	clear	horizontal	lines,	which	look	like	the	graphing	paper	kids
use	in	math	class.	By	default,	gray	gridlines	will	appear	every	two	centimeters	with	four	subdivisions:However,	these	settings	can	be	modified.	In	fact,	you	can	create	as	many	or	as	few	gridlines	as	you	want!	Simply	go	to	Photoshop>Preferences>Guides,	Grid	&	Slices.	Once	there,	you	can	change	the	color	of	the	gridlines,	the	type	of	gridlines,	the
separation	between	gridlines,	and	the	number	of	subdivisions.A	grid	can	act	as	a	visual	aid	that	helps	you	manually	place	elements	on	the	canvas	but	its	also	a	great	way	to	align	existing	elements	by	snapping	them	together.	You	see,	Photoshop	grids	offer	a	snap	feature.	Simply	select	View>Snap	to>Grid.	Then	whenever	you	move	an	element	across
the	canvas,	itll	align	with	the	closest	gridline!Its	important	to	remember:	The	grid	wont	print.	Its	a	visual	aid	only,	so	you	dont	need	to	worry	about	disabling	it	at	the	end	of	your	project.	(But	it	can	be	helpful	to	look	at	your	final	piece	without	a	grid;	that	way,	you	can	accurately	analyze	the	end	result.)	To	disable	the	grid,	simply	choose
View>Show>Grid.	Your	existing	grid	will	disappear,	and	if	you	head	back	to	the	menu,	the	Grid	option	will	be	unchecked.	As	I	explained	above,	guides	are	lines	that	you	manually	add	to	the	Photoshop	canvas.	You	can	choose	to	cover	the	whole	canvas	with	guides,	but	you	can	also	create	a	single	guide.	In	other	words,	you	can	create	guides	on	an	as-
needed	basis.	(Of	course,	you	can	always	create	both	a	grid	and	a	few	guides.	In	fact,	you	can	use	a	grid	to	better	position	your	guides!	Also,	note	that	guides,	like	grids,	wont	be	printed.)To	create	a	guide,	you	need	to	first	have	the	rulers	enabled,	so	go	ahead	and	select	View>Rulers.	(You	can	also	use	the	keyboard	shortcut	Ctrl/Cmd+R).Once	youve
done	this,	you	should	see	one	ruler	on	the	left	and	one	on	top	of	the	canvas.	To	create	a	horizontal	guide,	click	and	drag	from	the	top	ruler;	to	create	a	vertical	guide,	click	and	drag	from	the	left	ruler.Drag	your	guide	into	position,	then	let	go	of	the	mouse.	The	guide	will	remain	in	place,	and	you	can	continue	on	with	your	work	(or	you	can	choose	to
create	additional	guides).	If	you	misplace	the	guide	or	wish	to	move	it	later	on,	activate	the	Move	tool	from	the	toolbar.	Then	hover	over	the	guide	until	you	see	the	cursor	change	into	a	double	line	with	arrows.	Click	and	drag	to	move	the	guide	to	a	new	position.Its	also	possible	to	create	a	new	guide	that	appears	directly	on	the	Photoshop	canvas.
Select	View>Guide>New	Guide,	which	will	open	a	pop-up	dialog	box.	In	it,	you	can	set	the	lines	orientation,	position,	and	color.You	can	even	use	guides	to	create	a	custom	grid.	Head	to	View>Guide>New	Guide	Layout.	A	pop-up	dialog	box	will	appear,	where	you	can	indicate	the	number	of	columns	and	rows	you	want	to	create.	You	can	also	set	the
size,	gutter,	and	margin.	And	the	best	thing	about	this	option	is	that	you	can	save	each	new	layout	as	a	preset	and	load	it	in	future	documents.Note:	Since	you	can	move	guides	with	the	Move	tool	which	you	can	use	to	move	other	objects	they	can	be	moved	by	accident.	To	prevent	this,	make	sure	you	lock	your	guides	in	place.	Just	create	all	the	guides
you	need,	then	select	View>Guides>Lock	Guides.The	guides	also	have	a	snapping	feature,	which	you	can	use	to	accurately	position	elements	on	the	canvas.	Enable	it	by	selecting	View>Snap	to>Guides.If	you	wish	to	erase	a	guide,	just	drag	it	back	to	the	ruler.	Alternatively,	you	can	click	on	the	guide,	then	choose	View>Guide>Clear	Selected	Guide.
And	if	you	want	to	delete	every	guide,	click	View>Clear	Guides.	Photoshop	may	not	be	a	dedicated	graphic	design	program,	but	it	does	have	many	design-focused	tools	to	improve	your	workflow	including,	of	course,	grids	and	guides!Plus,	grids	and	guides	arent	just	useful	for	graphic	design;	you	can	also	use	them	to	help	you	scale	images,	make	photo
composites,	correct	perspective,	and	more.So	practice	creating	a	grid.	Have	fun	with	guides.	And	see	what	you	can	produce!Now	over	to	you:How	do	you	plan	to	use	grids	and	guides	in	your	photo-editing	and/or	design	work?	Share	your	thoughts	in	the	comments	below!Written	by	Steve	Patterson.In	this	tutorial,	we'll	learn	how	to	use	the	New	Guide
Layout	option	in	Photoshop	CC	to	easily	create	custom	guide	layouts.	With	one	simple	dialog	box,	the	New	Guide	Layout	feature	lets	us	create	any	number	of	rows	and	columns,	add	gutters,	margins,	and	even	save	our	guide	layouts	as	presets!The	New	Guide	Layout	option	is	only	available	in	Photoshop	CC	and	was	first	introduced	in	the	2014
Creative	Cloud	updates.	To	use	this	feature,	you'll	need	to	be	an	Adobe	Creative	Cloud	subscriber	and	you'll	want	to	make	sure	your	copy	of	Photoshop	CC	is	up	to	date.To	follow	along	with	this	tutorial,	you	don't	need	anything	fancy.	You	can	use	any	image	you	already	have	open	in	Photoshop	or	simply	create	a	new	Photoshop	document.	Here's	the
image	I	have	open	on	my	screen.	I	chose	this	one	simply	because	it's	an	interesting	texture	and	it's	nice	and	dark,	which	will	make	it	easy	for	us	to	see	the	guides	(grunge	wall	texture	from	Shutterstock):The	original	image.	Before	we	learn	all	about	the	New	Guide	Layout	feature,	let's	quickly	look	at	the	"old	way"	of	adding	guides.	Traditionally,	we
would	start	by	turning	on	Photoshop's	rulers	by	going	up	to	the	View	menu	in	the	Menu	Bar	along	the	top	of	the	screen	and	choosing	Rulers:Going	to	View	>	Rulers.This	places	the	rulers	along	the	top	and	left	side	of	the	document:The	rulers	are	now	visible	along	the	top	and	left.To	add	a	vertical	guide,	we	would	click	inside	the	ruler	on	the	left	and,
with	our	mouse	button	still	held	down,	we'd	drag	a	guide	out	from	the	ruler	into	the	document:Dragging	a	vertical	guide	out	from	the	ruler	on	the	left.To	add	a	horizontal	guide,	we'd	click	inside	the	ruler	along	the	top	and,	again	with	our	mouse	button	still	held	down,	we'd	drag	a	guide	downward	from	the	ruler	into	the	document:Dragging	a
horizontal	guide	out	from	the	ruler	along	the	top.This	way	of	adding	guides	by	dragging	them	out	from	the	rulers	still	works,	even	in	the	latest	versions	of	Photoshop,	but	in	Photoshop	CC,	there's	a	better	way,	and	that's	by	taking	advantage	of	the	New	Guide	Layout	option.	Let's	see	how	it	works.	The	New	Guide	Layout	OptionTo	access	the	New	Guide
Layout	option,	go	up	to	the	View	menu	at	the	top	of	the	screen	and	choose	New	Guide	Layout.	Again,	this	is	only	available	in	Photoshop	CC:Going	to	View	>	New	Guide	Layout.This	opens	the	New	Guide	Layout	dialog	box.	From	this	one	dialog	box,	we	can	easily	add	any	number	of	rows	and	columns	to	our	layout.	We	can	specify	an	exact	width	for	the
columns	or	an	exact	height	for	the	rows,	or	let	Photoshop	space	them	out	equally	for	us!	We	can	add	a	gutter	between	the	guides,	and	add	margins	along	the	top,	left,	bottom,	and	right	of	our	document.	We	can	even	save	our	custom	layout	as	a	preset	so	we	can	load	it	again	quickly	the	next	time	we	need	it!If	you	haven't	used	the	New	Guide	Layout
feature	before,	the	dialog	box	will	appear	with	its	default	settings,	which	adds	eight	columns	to	the	document,	each	separated	by	a	gutter	of	20	px.	There	are	no	rows	added	with	the	default	settings,	but	we'll	see	how	to	easily	add	rows	later:The	New	Guide	Layout	dialog	box.Here's	what	the	default	guide	layout	looks	like.	Notice,	though,	that	my	two
original	guides	(the	vertical	and	horizontal	guide	I	dragged	out	from	the	rulers)	are	still	there,	cutting	through	the	center	of	the	document:The	default	guide	layout,	plus	the	original	two	guides.	To	clear	away	any	previous	guides	and	keep	only	your	new	guide	layout,	select	the	Clear	Existing	Guides	option	at	the	bottom	of	the	dialog	box:Selecting
"Clear	Existing	Guides".And	now,	those	previous	guides	are	gone,	leaving	me	with	just	my	new	eight	column	layout:The	previous	guides	have	been	removed.	To	change	the	number	of	columns	in	the	layout,	simply	change	the	value	in	the	Number	field.	I'll	lower	the	value	from	8	to	4:Reducing	the	number	of	columns	from	8	to	4.Photoshop	instantly
updates	the	layout,	changing	the	number	of	columns	and	spacing	them	equally	from	left	to	right:The	layout	now	contains	four	equally-spaced	columns	instead	of	eight,	with	a	20	px	gutter	between	each	one.	If	you're	not	seeing	a	live	preview	of	your	changes,	make	sure	the	Preview	option	in	the	dialog	box	is	turned	on	(checked):The	Preview	option
should	be	checked.	The	space	between	the	columns	(and	rows)	is	known	as	the	gutter.	To	increase	or	decrease	the	gutter,	change	the	value	in	the	Gutter	field.	The	default	gutter	size	is	20	px,	which	adds	20	pixels	of	space	between	each	column.	I'm	actually	going	to	remove	the	gutter	completely	by	highlighting	the	Gutter	value	with	my	mouse	and
pressing	the	Backspace	(Win)	/	Delete	(Mac)	key	on	my	keyboard.	This	clears	the	Gutter	value	and	leaves	the	field	empty:Removing	the	space	between	the	columns	by	clearing	the	Gutter	value.With	the	Gutter	field	empty,	there's	no	longer	any	space	separating	the	columns:The	space	between	the	columns	has	been	removed.Download	all	of	our
Photoshop	tutorials	as	PDFs!Specifying	A	Column	WidthBy	default,	Photoshop	will	size	the	columns	automatically	so	that	they're	spaced	equally	across	the	document	from	left	to	right,	but	we	can	set	the	width	ourselves	by	entering	a	value	into	the	Width	field.	For	example,	I'll	enter	a	width	for	my	columns	of	150	px:Entering	a	specific	width	for	the
columns.Photoshop	again	updates	the	layout,	this	time	setting	the	width	of	each	column	to	exactly	150	px:The	layout	after	specifying	a	width	for	the	columns.	Notice	that	the	columns	are	no	longer	centered	in	the	document.	Instead,	they're	pushed	over	to	the	left.	To	center	them	after	you've	entered	a	specific	width,	select	the	Center	Columns	option
at	the	bottom	of	the	dialog	box:Turning	on	the	"Center	Columns"	option.With	Center	Columns	checked,	the	columns	are	once	again	centered	in	the	layout:The	layout	after	centering	the	columns.	To	add	rows	to	your	layout,	first	select	the	Rows	option	(it's	turned	off	by	default):Turning	on	the	rows.Then,	simply	enter	the	number	of	rows	you	need	into
the	Number	field.	You	can	enter	a	specific	height	for	each	row	into	the	Height	field,	or	leave	it	empty	and	let	Photoshop	space	them	out	equally.	You	can	also	enter	a	Gutter	value	to	add	space	between	each	row.In	my	case,	I'm	going	to	set	my	number	of	rows	to	3,	and	I'll	also	change	the	number	of	columns	to	3.	I'll	leave	the	Width	field	for	the
columns	and	the	Height	field	for	the	rows	empty	to	let	Photoshop	space	them	out	equally,	and	I'll	also	leave	the	Gutter	fields	empty:Setting	both	the	Columns	and	Rows	to	3.This	is	a	fast	and	easy	way	of	creating	a	standard	3	by	3	grid,	which	I	might	want	to	use	to	help	arrange	and	compose	the	various	elements	in	my	document	using	the	"rule	of
thirds":A	standard	3	by	3	grid	easily	created	with	the	New	Guide	Layout	feature.	To	add	margins	around	the	edges	of	the	document,	first	select	the	Margin	option	to	enable	it,	then	enter	the	amount	of	space	you	want	to	add	into	the	Top,	Left,	Bottom	and	Right	boxes.	In	my	case,	I'll	set	all	four	values	to	20	px:Adding	margins	to	the	layout.This	adds	20
pixels	of	space	around	the	inside	edges	of	my	document.	Photoshop	automatically	resizes	the	columns	and	rows	accordingly:The	same	3	by	3	layout	with	margins	added.We	can	even	add	negative	margins	by	simply	entering	negative	values.	Negative	margins	can	be	useful	when	adding	elements	to	a	document	or	making	selections	that	are	larger	than
the	document's	viewable	area	(the	canvas).	I'll	change	each	of	the	four	values	(Top,	Left,	Bottom,	and	Right)	to	-20	px:Adding	negative	margins	to	the	layout.This	gives	me	the	same	20	pixel-wide	margins	but	moves	them	outside	the	document's	viewable	area.	Once	again,	Photoshop	resizes	the	columns	and	rows	automatically:The	margins	now	sit
outside	the	document	area	rather	than	inside.	If	you	know	you'll	need	to	create	this	same	guide	layout	again	in	the	future,	you	can	save	time	by	saving	the	layout	as	a	preset.	Click	on	the	Preset	box	at	the	top	of	the	dialog	box	(where	it	says	"Custom"):Clicking	the	Preset	selection	box.This	opens	a	menu	with	a	few	built-in	preset	layouts	to	choose	from
(8	Column,	12	Column,	18	Column,	and	24	Column),	but	the	option	we	want	is	Save	Preset:Choosing	the	Save	Preset	option.When	the	Save	dialog	box	appears,	enter	a	descriptive	name	for	your	new	preset	into	the	Save	As	field.	I'll	name	mine	"cols-3-rows-3-margins-neg20px".	Then,	press	the	Save	button:Naming	and	saving	the	new	preset.With	the
layout	now	saved	as	a	preset,	the	next	time	you	need	it,	you'll	be	able	to	quickly	choose	it	from	the	Preset	list:The	custom	preset	now	appears	in	the	list.Once	you've	created	the	guide	layout	you	need,	click	OK	to	close	out	of	the	New	Guide	Layout	dialog	box:Clicking	OK	to	accept	the	new	layout.	To	temporarily	hide	your	guide	layout	from	view	in	the
document,	go	up	to	the	View	menu,	choose	Show,	then	choose	Guides.	Do	the	same	thing	again	to	turn	it	back	on.	Or,	simply	press	Ctrl+;	(Win)	/	Command+;	(Mac)	on	your	keyboard	to	toggle	the	guides	on	and	off:Going	to	View	>	Show	>	Guides	to	turn	the	layout	on	and	off.To	clear	the	guide	layout	completely,	go	up	to	the	View	menu	and	choose
Clear	Guides:Going	to	View	>	Clear	Guides.	1Open	Photoshop	on	your	computer.	If	youre	using	Windows,	youll	find	it	in	the	All	Apps	area	of	the	Start	menu.	In	macOS,	itll	be	in	the	Applications	folder.	2Open	the	project	you	want	to	edit.	You	can	do	this	by	clicking	the	Open	menu	at	the	top-left	corner	of	the	screen,	selecting	the	file,	and	then	clicking
Open.3Make	the	screen	rulers	visible.	If	you	dont	see	rulers	at	the	top	and	side	of	the	workspace,	click	the	View	menu	and	select	Rulers	to	enable	them.	This	makes	it	easy	to	place	guides,	as	well	as	objects	in	general.4Click	the	View	menu.	Its	at	the	top	of	the	screen.5Click	New	Guide.	Its	close	to	the	bottom	of	the	menu.	A	small	window	will
appear.6Select	a	position	for	the	first	guide	line.	Heres	how:Choose	either	Horizontal	or	Vertical	in	the	Orientation	section.Enter	the	ruler	position	(e.g.	12	cm)	where	you	want	the	guide	to	appear.	Don't	worry,	you	can	move	guides	around	the	workspace	at	any	time.Click	OK.	The	guide	(a	blue	line)	now	appears	over	the	workspace	at	the	location	you
entered.7Add	more	guides	as	needed.	Youll	usually	want	to	have	at	least	one	horizontal	and	one	vertical	guide	to	keep	your	objects	aligned.8Move	a	guide	line	to	a	different	ruler	position.	If	you	dont	like	where	you	placed	the	guide	line,	its	easy	to	move:[1]Press	and	hold	Ctrl	(Windows)	or	Cmd	(macOS))	on	the	keyboard.Move	the	mouse	pointer	over
the	guide	you	want	to	move.Click	and	drag	the	guide	to	its	new	position.9Remove	a	guide	thats	not	needed.	To	remove	one	guide,	just	drag	it	anywhere	outside	of	the	image	youre	working	on.[2]To	remove	all	guides	at	once,	click	the	View	menu	and	select	Clear	guides.10Lock	the	guides	into	place	(optional).	If	you	dont	want	to	lose	your	guide	lines,
you	may	want	to	lock	them	into	place.	To	do	this,	click	the	View	menu	and	select	Lock	Guides.If	you	need	to	move	or	remove	guides	after	locking	them,	youll	have	to	unlock	them	first.	Just	select	Unlock	Guides	from	the	View	menu.	Ask	a	Question	Written	by:	wikiHow	Technology	Writer	This	article	was	co-authored	by	wikiHow	staff	writer,	Nicole
Levine,	MFA.	Nicole	Levine	is	a	Technology	Writer	and	Editor	for	wikiHow.	She	has	more	than	20	years	of	experience	creating	technical	documentation	and	leading	support	teams	at	major	web	hosting	and	software	companies.	Nicole	also	holds	an	MFA	in	Creative	Writing	from	Portland	State	University	and	teaches	composition,	fiction-writing,	and
zine-making	at	various	institutions.	This	article	has	been	viewed	22,733	times.	Co-authors:	2	Updated:	June	29,	2021	Views:22,733	Thanks	to	all	authors	for	creating	a	page	that	has	been	read	22,733	times.	Did	you	know	that	Photoshop	has	grids	and	guidelines?	If	youre	eyeballing	your	lines	every	time	youre	correcting	a	buildings	perspective,
straightening	a	horizon,	or	placing	a	logo	on	a	photo,	then	Photoshops	grids	and	guides	can	make	a	huge	difference.	(And	thats	not	even	taking	into	account	everything	you	can	do	with	the	tools	if	you	create	flyers	or	do	any	other	graphic	design	work.)	In	this	article,	I	offer	a	quick	overview	of	Photoshops	positioning	tools.	I	explain	what	grids	and
guides	actually	are	and	how	to	create	them,	plus	I	share	some	tips	and	tricks	for	consistently	great	results.	Lets	dive	right	in,	starting	with	the	basics:	A	grid	is	a	series	of	horizontal	and	vertical	lines	that	covers	Photoshops	canvas,	like	this:	Grids	are	designed	to	make	it	easier	for	you	to	locate	specific	points	on	the	screen.	You	can	use	grids	to	create
symmetrical	designs	and	align	multiple	elements,	among	other	things.	Its	worth	noting	that	a	grid	is	just	a	visual	aid	inside	Photoshop;	the	gridlines	arent	saved	or	printed	on	the	image.	Guides	are	individual	lines	that	you	can	draw	across	the	Photoshop	canvas:	Guides	can	be	used	to	create	designs,	straighten	elements,	control	spacing,	and	much
more.	They	can	be	horizontal	or	vertical	lines,	and	like	grids,	they	are	only	visual	aids	inside	Photoshop;	if	you	save	your	image	without	first	removing	your	guides,	the	lines	wont	appear	in	the	final	file.	Creating	a	grid	is	easy.	Simply	head	into	the	Photoshop	menu,	then	select	View>Show>Grid.	Take	a	look	at	your	image,	and	you	should	see	a	series	of
lines	crisscrossing	the	page.	(Note:	Once	youve	enabled	grids,	if	you	select	View>Show,	youll	see	a	checkmark	next	to	the	Grid	option.	If	youre	ever	unsure	about	whether	grids	are	enabled,	simply	go	to	View>Show	and	look	for	that	checkmark!)	Photoshops	grid	has	clear	horizontal	lines,	which	look	like	the	graphing	paper	kids	use	in	math	class.	By
default,	gray	gridlines	will	appear	every	two	centimeters	with	four	subdivisions:	However,	these	settings	can	be	modified.	In	fact,	you	can	create	as	many	or	as	few	gridlines	as	you	want!	Simply	go	to	Photoshop>Preferences>Guides,	Grid	&	Slices.	Once	there,	you	can	change	the	color	of	the	gridlines,	the	type	of	gridlines,	the	separation	between
gridlines,	and	the	number	of	subdivisions.	A	grid	can	act	as	a	visual	aid	that	helps	you	manually	place	elements	on	the	canvas	but	its	also	a	great	way	to	align	existing	elements	by	snapping	them	together.	You	see,	Photoshop	grids	offer	a	snap	feature.	Simply	select	View>Snap	to>Grid.	Then	whenever	you	move	an	element	across	the	canvas,	itll	align
with	the	closest	gridline!	Its	important	to	remember:	The	grid	wont	print.	Its	a	visual	aid	only,	so	you	dont	need	to	worry	about	disabling	it	at	the	end	of	your	project.	(But	it	can	be	helpful	to	look	at	your	final	piece	without	a	grid;	that	way,	you	can	accurately	analyze	the	end	result.)	To	disable	the	grid,	simply	choose	View>Show>Grid.	Your	existing
grid	will	disappear,	and	if	you	head	back	to	the	menu,	the	Grid	option	will	be	unchecked.	As	I	explained	above,	guides	are	lines	that	you	manually	add	to	the	Photoshop	canvas.	You	can	choose	to	cover	the	whole	canvas	with	guides,	but	you	can	also	create	a	single	guide.	In	other	words,	you	can	create	guides	on	an	as-needed	basis.	(Of	course,	you	can
always	create	both	a	grid	and	a	few	guides.	In	fact,	you	can	use	a	grid	to	better	position	your	guides!	Also,	note	that	guides,	like	grids,	wont	be	printed.)	To	create	a	guide,	you	need	to	first	have	the	rulers	enabled,	so	go	ahead	and	select	View>Rulers.	(You	can	also	use	the	keyboard	shortcut	Ctrl/Cmd+R).	Once	youve	done	this,	you	should	see	one
ruler	on	the	left	and	one	on	top	of	the	canvas.	To	create	a	horizontal	guide,	click	and	drag	from	the	top	ruler;	to	create	a	vertical	guide,	click	and	drag	from	the	left	ruler.	Drag	your	guide	into	position,	then	let	go	of	the	mouse.	The	guide	will	remain	in	place,	and	you	can	continue	on	with	your	work	(or	you	can	choose	to	create	additional	guides).	If	you
misplace	the	guide	or	wish	to	move	it	later	on,	activate	the	Move	tool	from	the	toolbar.	Then	hover	over	the	guide	until	you	see	the	cursor	change	into	a	double	line	with	arrows.	Click	and	drag	to	move	the	guide	to	a	new	position.	Its	also	possible	to	create	a	new	guide	that	appears	directly	on	the	Photoshop	canvas.	Select	View>Guide>New	Guide,
which	will	open	a	pop-up	dialog	box.	In	it,	you	can	set	the	lines	orientation,	position,	and	color.	You	can	even	use	guides	to	create	a	custom	grid.	Head	to	View>Guide>New	Guide	Layout.	A	pop-up	dialog	box	will	appear,	where	you	can	indicate	the	number	of	columns	and	rows	you	want	to	create.	You	can	also	set	the	size,	gutter,	and	margin.	And	the
best	thing	about	this	option	is	that	you	can	save	each	new	layout	as	a	preset	and	load	it	in	future	documents.	Note:	Since	you	can	move	guides	with	the	Move	tool	which	you	can	use	to	move	other	objects	they	can	be	moved	by	accident.	To	prevent	this,	make	sure	you	lock	your	guides	in	place.	Just	create	all	the	guides	you	need,	then	select
View>Guides>Lock	Guides.	The	guides	also	have	a	snapping	feature,	which	you	can	use	to	accurately	position	elements	on	the	canvas.	Enable	it	by	selecting	View>Snap	to>Guides.	If	you	wish	to	erase	a	guide,	just	drag	it	back	to	the	ruler.	Alternatively,	you	can	click	on	the	guide,	then	choose	View>Guide>Clear	Selected	Guide.	And	if	you	want	to
delete	every	guide,	click	View>Clear	Guides.	Photoshop	may	not	be	a	dedicated	graphic	design	program,	but	it	does	have	many	design-focused	tools	to	improve	your	workflow	including,	of	course,	grids	and	guides!	Plus,	grids	and	guides	arent	just	useful	for	graphic	design;	you	can	also	use	them	to	help	you	scale	images,	make	photo	composites,
correct	perspective,	and	more.	So	practice	creating	a	grid.	Have	fun	with	guides.	And	see	what	you	can	produce!	Now	over	to	you:	How	do	you	plan	to	use	grids	and	guides	in	your	photo-editing	and/or	design	work?	Share	your	thoughts	in	the	comments	below!

How	to	draw	guidelines	in	photoshop.	Photoshop	guideline.	Photoshop	guide	layout.	How	to	add	guides	in	photoshop.	How	to	create	guidelines	in	photoshop.	How	to	put	guidelines	in	photoshop.
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